Jump to content


Carriots for Arduiono problems

  • Please log in to reply
2 replies to this topic

#1 tractorman1960



  • Members
  • Pip
  • 1 posts

Posted 11 December 2016 - 01:12 AM

I love the idea of Carriots, just not able to get it working so far.  I've downloaded, unzipped, and added the library.  I have tried a couple of the tutrorial example sketches and have encountered a few obstacles:


1.  When changing the device Id.developer to my "defaultDevicefrom@userID" and run the Arduino compiler, I get an error message that there is "a stray '@' in program"  so this is a prevents compiling unless there is a way to remove the @ from the Id.developer string.


2.  I use Windows 10 and have unzipped the Carriots for Arduino library file using 7-zip and add it to my Ardinos Libraries folder.  The folder shows up on my computer, documents, Arduino, Library directory but when I go to find it in my Arduino IDE it is not there.  It doesn't seem to stay intact as a folder but extracts to its components including CarriotsSend.h  readme.txt and CariotsClients.tar.  So I can't include the library in sketches.


Any help?

#2 sreejith.nair



  • Members
  • Pip
  • 6 posts

Posted 26 February 2018 - 11:14 AM

Which Arduino Device you are using?

Which interface you are using for carriots connection ? ( Wifi Shield, Ethernet shield, etc).


In which example project you are facing issue? 

Please be specific to one example, so that i can help you to debug that. 

#3 Wolcen



  • Members
  • Pip
  • 1 posts

Posted 18 March 2018 - 06:10 PM

I have the same problem, i solved it keeping " ", "defaultDevicefrom@userID".

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users